Requirements for Joomla 1.5.x

Software Recommended Minimum More information
PHP* 5.2 + 4.3.10 http://www.php.net
MySQL** 4.1.x + 3.23 http://www.mysql.com
Apache***
(with mod_mysql, mod_xml,
and mod_zlib)
2.x + 1.3 http://www.apache.org
Microsoft IIS**** 7 6 http://www.iis.net

 

*Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.

**Joomla is not yet compatible with MySQL 6.x.

***In order to use SEO URLs, you will need to have the Apache mod_rewrite extension installed.

****For Microsoft IIS (depending on your setup) you may need the following:

For further assistance using Microsoft IIS, visit the Joomla IIS forum.

Joomla 1.6 will require PHP 5.2+ and MySQL 5.0.4+.

Configuration Options

If installing on a local computer, there are a number of packages that will help you get set up quicker than individual installations:

If you need other options, we recommend visiting our installation forums for more information.

 

Related Posts

Leave a reply

+ 67 = 69

WordPress spam blocked by CleanTalk.